+4
Fixed

The App is not opening anymore. When I click on it i used to open, but now it closes immediately. What gives?

Mikael Nordlin 5 years ago in iOS • updated by Maarten Billemont 4 years ago 1

 Similar behaviour has been noted previously, particularly when several apps rely on the address book database which gets corrupted somehow. The situation is normally resolved by rebooting the iPhone, but this remedy does not apply here as I've restarted the device several times already.


I would reinstall the App but hesitate to do so in fear of losing my passwords, which are supposed to be not stored anywhere. I've activated iCloud synd though, could this be the culprit? So, I'm running the app on another iPhone also. The other iPhone won't run the app either as of today.

Usability

Hey Mikael,


Your problem is a known issue in the latest version of Master Password and I'm already working on a fix.


A few people have reported that for them, the app stopped opening with the latest version.  Many others report no issues.  I have also heard that upgrading to iOS 6 has solved the problem for those that tried.


The issue appears to be caused by iOS code while the UI is being initialized and started as a result of building the latest Master Password release using the new iOS 6 developer tools.  I have a work-around that solves the issue but it might take some time for Apple to review it.  In the mean time, you're free to either try upgrading to iOS 6 or sign up with Lyndir's TestFlight.  Via TestFlight, I can prepare a custom build for you with the work-around included and you can install it on your phone by opening the TestFlight app that will appear on your phone as a result of signing up.


You can sign up for Lyndir's TestFlight here: http://tflig.ht/vNN5Zi


Let me know if there's anything else I can help you with.  There are other options as well for more advanced users: Master Password has a working Java/CLI version, for instance.